WordPress 2.1 MySQL Requirements

After discussing whether we should drop MySQL 3.23.23 support with users, developers, and hosting providers, we’ve reached the following roadmap.  The WordPress 2.0.x branch will continue to support 3.23.23 for the foreseeable future, and WordPress 2.1 will require MySQL 4.0.  Many people, especially plugin developers, wanted WordPress 2.1 to require MySQL 4.1.  There are still a number of hosts running 4.0, however, so we decided to postpone bumping to 4.1 until WordPress 2.2 comes out.  Hopefully this will give everyone sufficient notice to upgrade their installations.  Since MySQL AB has discontinued support for 4.0, upgrading seems like a good idea regardless of what WordPress requires.

30 thoughts on “WordPress 2.1 MySQL Requirements

  1. A good rule of thumb is to follow what Debian calls its stable release (Sarge right now, Etch in 2-3 months). That accounts for a good chunk of servers out there and it’s not too cutting edge.

  2. Hostmonster currently runs the MySQL version 4.1.14-standard. We will upgrade to v.5 when cPanel upgrades their software.

  3. Pingback: T. Longren
  4. I don’t really get this why just not bump it up all the way and don’t make something half done for wordpress 2.2 make it php5 and mysql5.2..

    Make a statement make it CLEAR AND LOUD in time so everybody just knows it WordPress 2.2 get some class got damn it.

    If you look at the sourcecode now it’s fixes and mixes in the code for old things everywere…

    Should be about time to get out old source code for good, fix a nice version for the future in minds just my thoughts anyway.

    And everybody can talk to there hosts in time so they have time to make mysql upgrade available or php mostly allready is 5 on all host companys anyway and you mostly have the ability to change between 4 and 5.

    In my opinion i think alot of folks looking around for other solutions out there they looking for change so i think wordpress need this for it community aspects. I really think it’s true.

  5. Have to agree with Xmion. It’s such a hassle and really confusing. Not that nice to wordpress users. Still love wordpress though, great stuff.

  6. Xnion and Al, ever considered that the vast majority of WP users have no influence over what version of MySQL runs on their server? By requiring, say, PHP5, you’re effectively locking out a large number of users, as they don’t meet the minimum requirements anymore.

  7. I think it was a right decision, of supporting mysql 3.23 for some time in 2.0.x branch, as for wordpress 2.1.x requiring 4.0 i don’t know about the statistics that you have got, but i believe, that pushing up technology and leaving behind elder stuff is necessary for the progress to occur.

  8. Pingback: » Wordpress 2.0.7
  9. Pingback: SigT
  10. Hey André! What wordpress really need is a huge cleanup and refresh in sourcecode and bump it up all the way.

    But to make that happen you really need to get that out to the user community not only on the roadmap for developing, as i said before in time so hosts can make a upgrade for there userbase.

    And i do think that majority have influence over what version there server is runnin’. I really think the host company listen to what user has to say OR THEY LOSE THERE MONEY and influence on the market. Host companys really carres this days look around, you will see.

    And to lock out people i don’t think you do that because the wordpress community is big. Lets face it everything has to move on sooner or later. And to make a such huge thing is to have two version as we have here in this stage of 2.1 coming is that people that haven’t upgrade there server or talk to there host don’t upgrade imideatly they wait a month or so. And in my aspects that is what almost every user do anyway because of there plugins and themes has to be updated first. I hope this make sense to you because to it does.

Leave a Reply