WordPress has required PHP 4.2 or greater for awhile now. With WP 2.5 this will change. No, we’re not going to require PHP 5. We are merely bumping our requirement from 4.2 to 4.3. Some 4.3 specific functions slipped into WP 2.3, so we already have a 4.3 requirement in a few areas. Those accidental 4.3 dependencies haven’t created any great outcry, so a requirement bump to 4.3 seems safe for the vast majority of our user base. Moving our requirement up to 4.3 allows us to drop some PHP 4.2 compatibility code and forgo jumping through hoops to avoid using 4.3 specific functionality.
With PHP4 support being discontinued, we’ll be evaluating our PHP requirement with each release of WP. For now we’re being conservative with a move to PHP 4.3.