PHP 4.3 required by WP 2.5

WordPress has required PHP 4.2 or greater for awhile now. With WP 2.5 this will change. No, we’re not going to require PHP 5. We are merely bumping our requirement from 4.2 to 4.3. Some 4.3 specific functions slipped into WP 2.3, so we already have a 4.3 requirement in a few areas. Those accidental 4.3 dependencies haven’t created any great outcry, so a requirement bump to 4.3 seems safe for the vast majority of our user base. Moving our requirement up to 4.3 allows us to drop some PHP 4.2 compatibility code and forgo jumping through hoops to avoid using 4.3 specific functionality.

With PHP4 support being discontinued, we’ll be evaluating our PHP requirement with each release of WP. For now we’re being conservative with a move to PHP 4.3.

8 thoughts on “PHP 4.3 required by WP 2.5

  1. I fully appreciate your conservative outlook on development. I have a few dozen client websites running WordPress and the upgrade process can be a difficult thing to manage when each client is on a different hosting platform.

  2. Ryan,

    Well, the second that WordPress is ready to move to PHP5, I’ll be right there waiting!

    There are some great things I’ve seen in PHP5 and I think WordPress could really start taking advantage of those features. Even with PHP6 — it is, yes, still a long ways off — WordPress would be able to take advantage of some huge scripting features.

    I’m excited to see the direction of WordPress and to see where it’s going.

    But let’s bump up that PHP5 requirement asap! It would help “encourage” web hosts to make the switch too. Many web hosts are holding back and staying on PHP4, sadly.

    I host myself, so it’s not an issue, but I’m speaking for everyone else out there on shared hosting.

    Thanks again for the updates!

Leave a Reply