In the Trunk

Here’s a quick rundown of new stuff that has gone into trunk for WP 2.2.

WordPress 2.1 MySQL Requirements

After discussing whether we should drop MySQL 3.23.23 support with users, developers, and hosting providers, we’ve reached the following roadmap.  The WordPress 2.0.x branch will continue to support 3.23.23 for the foreseeable future, and WordPress 2.1 will require MySQL 4.0.  Many people, especially plugin developers, wanted WordPress 2.1 to require MySQL 4.1.  There are still a number of hosts running 4.0, however, so we decided to postpone bumping to 4.1 until WordPress 2.2 comes out.  Hopefully this will give everyone sufficient notice to upgrade their installations.  Since MySQL AB has discontinued support for 4.0, upgrading seems like a good idea regardless of what WordPress requires.

Should WP drop MySQL 3.23 support?

WordPress currently requires MySQL 3.23.23 or greater. We’ve long avoid bumping our requirements so that we could accommodate the widest variety of hosting environments. We understand that people don’t want to upgrade a platform that is working just fine for them. However, supporting these older versions adds development and support costs. Recently, a commit went into trunk that bumped the MySQL requirement from 3.23.23 to 4.0 or greater. Considering that MySQL AB is dropping support for 3.23 and no longer provides binary downloads for 3.23, is it time for WordPress to move on? How many of you are still running 3.23?

Please note that this requirement change affects the upcoming 2.1 release only. The WordPress 2.0 series still supports 3.23 and will for the foreseeable future.